Loading...
Zero-K Name:     OR   Password:   

Game crash

25 posts, 403 views
Post comment
Filter:    Player:  
Page of 2 (25 records)
sort

USrankreaver118
8 days ago
Can anyone help me? My game crashes after 10-20 mins playing, sometimes sooner, and sometimes later than that. It just started happening recently.
+0 / -0




AUrankAdminGoogleFrog
8 days ago
I don't have any crash report from you. I recently set an engine with a bugfix for midgame crash so try again.
+0 / -0



RUrankFirepluk
8 days ago
dis is just sad
Where is goddamn auto crash report?...
+0 / -0




AUrankAdminGoogleFrog
8 days ago
Auto crash report exists. It was vital in solving other crashes. Get chobby to do it.
+3 / -0


CHrankAdminDeinFreund
8 days ago
Infolog next time please
+1 / -0

USrankreaver118
7 days ago
I did send one about a week ago and I tried playing again today and did the same thing. Also sent another crash report
+0 / -0


CHrankAdminDeinFreund
7 days ago
(edited 7 days ago)

Sorry then, the crash reports are not sorted to find individual cases.
+0 / -0


RUrankAdminikinz
7 days ago
(edited 7 days ago)

Did you do that as "reaver118"? https://github.com/ZeroK-RTS/CrashReports/search?utf8=%E2%9C%93&q=reaver118 doesn't list reports with you as the user (the other seven are people who saw you in #zk so they got a server message that you existed).
+1 / -0

USrankreaver118
7 days ago
Yea I guess so. I was just ingame and after it crashed it said that it sent some report that "could contain chat", and it asked me if I was sure I wanted to send it

+0 / -0


RUrankAdminikinz
7 days ago
(edited 7 days ago)

Maybe the crash report thing is broken. Right after it crashes (important because it gets overwritten if you start zk again!) find Steam/SteamApps/common/Zero-K/infolog.txt and put it on http://pastebin.com and post the link here.
+0 / -0

USrankreaver118
7 days ago
It won't let me upload the whole infolog at once on pastebin.

http://pastebin.com/L693BzhQ

Then i skipped all the things that repeated. Idk if they were needed or not, and I went straight to the errors it was right after this one: [f=0024082] Fragment shader was successfully compiled to run on hardware.

http://pastebin.com/Ldpj1HiF
+1 / -0

USrankreaver118
6 days ago
...
+0 / -0

GBrankTheEloIsALie
6 days ago
Looks like it's trying to compile/link the shader every frame and eventually runs out of memory...
+0 / -0




AUrankAdminGoogleFrog
6 days ago
USrankreaver118 I'll need to whole infolog.
+0 / -0

USrankreaver118
6 days ago
it wont let me post it all. I keep sending crash reports

+0 / -0



MYrankAdminKingRaptor
6 days ago
Did anything with drivers recently? (Seems unlikely for a nine year old card though)

As a temporary workaround you could open springsettings.cfg (in the same folder as infolog) and adding the line LuaShaders = 0.
+0 / -0


RUrankAdminikinz
6 days ago
(edited 6 days ago)

USrankreaver118 you can put the entire infolog on http://www.filedropper.com (or better yet Google Drive if you have a google acc). The size limit on pastebin is pretty low.

To think of it, maybe the auto crash repot thing fails because the log is too big. It should look at the size and if it's too large truncate it in the issue body and attach the full log gzipped as an issue attachment.
+3 / -0

USrankreaver118
5 days ago
http://www.filedropper.com/infolog
+0 / -0

USrankreaver118
4 days ago
...
+0 / -0


RUrankAdminikinz
4 days ago
Did you update your graphics drivers recently before it started happening? Try enabling safe mode in settings.

If safe mode fails and you didn't change drivers then it's probably an engine regression. We'll have to find the engine version that introduced the bug. I'm not sure what the canonical way to that is with Chobby.
+0 / -0
Page of 2 (25 records)