Loading...
  OR  Zero-K Name:    Password:   

Forum index  > News   >

Zero-K v1.4.9.0 to Zero-K v1.4.9.2

12 posts, 1233 views
Post comment
Filter:    Player:  
sort




AUrankAdminGoogleFrog
11 months ago

Starlight finally has a new model, something more fitting of the most expensive thing you can build. Starlight might see more use as Bantha has received a nerf as a result of free-for-all and endgame feedback. Smaller units have also received attention with many unit AI improvements and a fix for non-functional slow weaponry.

Balance



Bantha:
  • Larger Hitvolume: It is now a 60 radius cylinder instead of a 55 wide and 35 deep box. This should make it weaker to spread weapons and Ultimatium.
  • Reduced Speed 1.72 -> 1.55. This puts it between Dante and Detriment instead of approximately the same as Dante. It can still skirmish Detriment with no problem.
  • Reduced Health 36k -> 32k.

Detriment:
  • LargerHitvolume: radius 80 cylinder -> radius 92. It was looking a bit thin in comparison to Bantha.

Starlight:
  • Size 8x8 -> 10x10

Fixed slow damage.

Unit AI


  • Most precise unguided rockets and plasma cannons now have overkill prevention against structures. This is an improvement for many assaults, precise artillery, Rocko and Rogue.
  • Added overkill prevention for Placeholder. They try to avoid overlapping their shots (unless against a particularly heavy foe).
  • Mid-range units avoid explosive structures (Fusions, Pylons etc...).
  • Fixed some Scorcher dive and heatray target priority bugs.
  • Wolverines now skirmish everything.
  • Added tactical AI for Impaler, Pillager, Bantha and Grizzly
  • Anti-heavies now prioritize heavy units more strongly.
  • Reduced the target priority of unidentified radar dots.
  • Reduced the target priority of wobbling radar dots for unguided precise weapons.

Fixes and Interface


  • Added ingame ignore.
  • The camera now zooms to your startbox upon commander selection.
  • Fixed cloaked flying Blastwings.
  • Fixed Shredder wreck.

Added map boxes:
  • Harbinger
  • Sands of War
  • Added fallback boxes.

+12 / -0



EErank[ISP]Lauri
11 months ago
quote:
Added tactical AI for ... Pillager

What does it do? Does it try to kite stuff?
+0 / -0

DErankCHmux2
11 months ago
Oh my... I got that new update.

Now I can´t start then game anymore.
The log ist below.

ANy ideas of how to fix this?

Thanks in advance.





[ParseCmdLine] command-line args: "C:\Users\User\Documents\My Games\Spring\engine\103.0.1-129-g98e3979\spring.exe --config "C:\Users\User\Documents\My Games\Spring\springsettings.cfg" "C:\Users\User\AppData\Local\Temp\tmp9AB4.tmp""
Using configuration source: "C:\Users\User\Documents\My Games\Spring\springsettings.cfg"
============== <User Config> ==============
3DTrees = 0
AdvMapShading = 0
AdvSky = 1
AdvUnitShading = 0
AllowDeferredMapRendering = 1
AllowDeferredModelRendering = 1
BumpWaterAnisotropy = 2
BumpWaterBlurReflection = 1
BumpWaterDepthBits = 16
BumpWaterReflection = 2
BumpWaterRefraction = 0
BumpWaterShoreWaves = 0
BumpWaterTexSizeReflection = 128
CamMode = 1
CamTimeExponent = 4.0
CamTimeFactor = 1.0
CompressTextures = 1
DualScreenMiniMapOnLeft = 1
DynamicSky = 1
FPSFOV = 90
FSAALevel = 2
Fullscreen = 0
GroundDetail = 176
GroundScarAlphaFade = 1
HangTimeout = 0
HardwareCursor = 1
HighResLos = 1
InitialNetworkTimeout = 0
InputTextGeo = 0.26 0.73 0.02 0.028
LODScale = 1.000
LODScaleReflection = 1.000
LODScaleRefraction = 1.000
LODScaleShadow = 1.000
LastSelectedMap = Tropical
LastSelectedMod = Zero-K $VERSION
LastSelectedScript = Commanders
LoadingMT = 0
MaxDynamicMapLights = 0
MaxDynamicModelLights = 0
MaxParticles = 20000
MaxSounds = 32
MaximumTransmissionUnit = 0
MiddleClickScrollSpeed = -0.005
MouseDragScrollThreshold = 0
ReconnectTimeout = 0
ScreenshotCounter = 6
ScrollWheelSpeed = -25
ShadowMapSize = 8192
Shadows = 1
ShowClock = 0
ShowPlayerInfo = 0
SmoothLines = 1
TreeRadius = 1000
UnitIconDist = 151
UnitLodDist = 9999
UsePBO = 0
VSync = 1
WindowBorderless = 1
WindowPosX = 0
WindowPosY = 0
WindowedEdgeMove = 0
XResolution = 1680
YResolution = 1050
snd_airAbsorption = 0
snd_volmaster = 13
============== </User Config> ==============
Available log sections: KeyBindings, AutohostInterface, GameServer, Net, CSMFGroundTextures, RoamMeshDrawer, BumpWater, DynWater, SkyBox, DecalsDrawerGL4, FarTextureHandler, Model, Piece, OBJParser, ModelRenderContainer, Shader, Texture, Font, CregSerializer, ArchiveScanner, VFS, Sound, LuaSocket, GroundMoveType, Path
Enabled log sections: Sound(Notice)
Enable or disable log sections using the LogSections configuration key
or the SPRING_LOG_SECTIONS environment variable (both comma separated).
Use "none" to disable the default log sections.
LogOutput initialized.
Spring 103.0.1-129-g98e3979 develop
Build Environment: boost-105500, GNU libstdc++ version 20130531
Compiler Version: gcc-4.8.1
Operating System: Microsoft Windows
Microsoft Home Premium Edition, 64-bit (build 9200)
AMD A8-6600K APU with Radeon(tm) HD Graphics ; 7346MB RAM, 14770MB pagefile
Word Size: 32-bit (emulated)
CPU Clock: win32::TimeGetTime
Physical CPU Cores: 4
Logical CPU Cores: 4
[CMyMath::Init] CPU SSE mask: 1023, flags:
SSE 1.0: 1, SSE 2.0: 1
SSE 3.0: 1, SSSE 3.0: 1
SSE 4.1: 1, SSE 4.2: 1
SSE 4.0A: 1, SSE 5.0A: 1
using streflop SSE FP-math mode, CPU supports SSE instructions
Supported Video modes on Display 1 x:0 y:0 1680x1050:
640x480, 720x480, 800x480, 720x576, 800x600, 1024x600, 1280x720, 1024x768, 1280x768, 1280x800, 1152x864, 1440x900, 1280x960, 1280x1024, 1400x1050, 1680x1050
SDL version: linked 2.0.4; compiled 2.0.4
GL version: 4.5.13399 Compatibility Profile Context 15.201.1151.1008
GL vendor: ATI Technologies Inc.
GL renderer: AMD Radeon HD 8570D
GLSL version: 4.40
GLEW version: 1.5.8
Video RAM: unknown
SwapInterval: 0
GL info:
haveARB: 1, haveGLSL: 1, ATI hacks: 1
FBO support: 1, NPOT-texture support: 1, 24bit Z-buffer support: 0
maximum texture size: 16384, compress MIP-map textures: 1
maximum SmoothPointSize: 63, maximum vec4 varying/attributes: 32/29
maximum drawbuffers: 8, maximum recommended indices/vertices: 16777215/2147483647
number of UniformBufferBindings: 90 (64kB)
Using VSync
[InitOpenGL] video mode set to 1680x1050:24bit @60Hz (windowed)
[WatchDog::Install] disabled
[WatchDog] registering controls for thread [main]
[ThreadPool::SetThreadCount][1] #wanted=4 #current=1 #max=4
[ThreadPool::SetThreadCount][2] #threads=3
[DataDirs] Isolation Mode!
Using read-write data directory: C:\Users\User\Documents\My Games\Spring\
Using read-only data directory: C:\Users\User\Documents\My Games\Spring\engine\103.0.1-129-g98e3979\
Scanning: C:\Users\User\Documents\My Games\Spring\engine\103.0.1-129-g98e3979\base
Scanning: C:\Users\User\Documents\My Games\Spring\maps
Scanning: C:\Users\User\Documents\My Games\Spring\games
Scanning: C:\Users\User\Documents\My Games\Spring\packages
CArchiveScanner: 27 ms
[f=-000001] [Font] Error: Failed creating font: Couldn't find font 'fonts/FreeSansBold.otf'.
[f=-000001] [Font] Error: Failed creating font: Couldn't find font 'fonts/FreeSansBold.otf'.
[f=-000001] Error: [ErrorMessageBox][1] msg="Failed to load FontFile: fonts/FreeSansBold.otf, installation of spring broken? did you run make install?" IsMainThread()=1 fromMain=0
[f=-000001] Error: [ErrorMessageBox][2]
[f=-000001] [SpringApp::ShutDown][1]
[f=-000001] [ThreadPool::SetThreadCount][1] #wanted=0 #current=4 #max=4
[f=-000001] [ThreadPool::SetThreadCount][2] #threads=0
[f=-000001] [SpringApp::ShutDown][2]
[f=-000001] [SpringApp::ShutDown][3]
[f=-000001] [SpringApp::ShutDown][4]
[f=-000001] [SpringApp::ShutDown][5]
[f=-000001] [SpringApp::ShutDown][6]
[f=-000001] [SpringApp::ShutDown][7]
[SpringApp::ShutDown][8]
[WatchDog] deregistering controls for thread [main]
[WatchDog::Uninstall][1] hangDetectorThread=00000000
[SpringApp::ShutDown][9]
Error: [ErrorMessageBox][3]
Error: [ErrorMessageBox][4]
Fatal: Spring: Incorrect/Missing content:
Failed to load FontFile: fonts/FreeSansBold.otf, installation of spring broken? did you run make install?

+0 / -1


CZrankAdminLicho
11 months ago
(edited 11 months ago)

What lobby program have you used?
What verison?
+0 / -0

DErankCHmux2
11 months ago
Zero-K v1.4.9.2

The problem started right after the update.

i have been playing then game one hor before on 1.4.9.0 without any trouble.


+0 / -0

DErankCHmux2
11 months ago
I got it working again.

there was a spring dev (103.bla development-folder without fonts subfolder.
i deleted the whole dev-folder and tried again.

problem solved...

+2 / -0

USrank_Shaman
11 months ago
quote:
Failed to load FontFile: fonts/FreeSansBold.otf, installation of spring broken? did you run make install?


Take FreeSansBold.otf from any installation of spring, and move it to engine/103.0.1-129-g98e3979/fonts. Simple fix.

PS: in the future [url=www.pastebin.com]pastebin[/url] your infolog.
+0 / -0


AUrank4hundred
11 months ago
I understand the relevent changes compared to banther, but Detriment is really bad these days, Maybe it needs a small buff elsewhere?
+0 / -0




AUrankAdminGoogleFrog
11 months ago
The Detriment change is mostly because its hitbolume looked wrong for its size.
+0 / -0

PLrankzenfur
11 months ago
I miss old starlight model already. It wasn't ugly at all. Looking at this picture I'm visualising singu on top of current model and laser being emitted from the sphere with rapidly spinning 3 claws around singu model. That would be more fitting and epic :P

Also... why epic weapons don't explode like singu given how much energy is going through them? High risk high reward!
+0 / -0

USrank_Shaman
11 months ago
(edited 11 months ago)

It should have a huge main explosion followed by a satellite crash causing another massive explosion.

Go big or go home.
+9 / -0

ITrankOldGhostStalker
8 months ago
Also it should be spinning (boht uppar and lower parts, one clockwise the other counterclockwise)
+0 / -0