Loading...
  OR  Zero-K Name:    Password:   

shields stop working after some time and corrupt saved games

5 posts, 80 views
Post comment
Filter:    Player:  
sort

CArankni
6 days ago
I want to start by saying thanks to all the people who contributed to spring RTS engine and Zero-K, great job everyone, very good game. However there are some issues that need to be fixed. Please see below.

After playing the game for a while (time seems random, could be around 10 minutes to 1 hour), the shield bubbles for shield buildings and shielded units disappear completely and seem to be non functional even with more then enough power/energy income.

In this state, the natural reaction is to save the game and restart zero-k and hope that the issue goes away. However this is not the case. If you save the game in this state and then try to load it again, you will be taken to the same map but it will be as if you started a brand new game and are asked to select a commander and a start location.

There are two bugs here:
1 the shields stop working and/or disappear.
2 the save/load feature is broken and the saved game is corrupted

Reproduced using some or all of the following steps (not all steps may be required but capturing for completeness):
-play the game, build shield generators and bots with shields
-save the game periodically sometimes on new save files, sometimes overwriting existing ones
-after a save, load up the game immediately from the same save file (I did this to test that saves were working as this corruption happened to me before)
-fix issues with save/load by turning on repeat on factories, removing extra units that were added to factory queues, issue guard orders to caretakers (I captured these issues in another post)
-continue playing and saving and load periodically

Note that after a while, during play, the shields will just disappear completely for no apparent reason. Saving and loading the game now will result in the issue I described above.

I reproduced these issues in a skirmish game of 1 human vs 1 AI. The AI was basic or novice. I got the behaviour on two separate maps so far. One was fields of isis, but I suspect it happens on all maps when the shield bubbles disappear as that is what happened in both maps.


Please fix these issues.
+0 / -0


AUrankAdminAquanim
6 days ago
(edited 6 days ago)

Do the shields break in a game where no save/reload has occured? Save/reload is a bit of a work in progress as I understand it.
+0 / -0

CArankni
6 days ago
I don't know. I'm just mentioning all the steps in case they matter. So far I've always used saves as they are really important to me.

I would love to have save/load fully working.

Can you provide some background on the save feature. How new is it? Is it still being worked on? Who supports it, engine, zero-k or likely both. etc.
+0 / -0



AUrankAdminGoogleFrog
6 days ago
It sounds like a shield crash which then breaks the ability to save games. It is likely a graphics crash because I would know about it if shields crashed after 10 minutes for everyone. You need to click the send bug report button under "Help" in the main menu when this occurs to submit a report with logs. A replay of the game may also be useful.
+0 / -0

CArankni
6 days ago
Ok I got it again, in a 29 min game.

I used the guardian commander (in case it matters). 1 v 1 beginner ai skirmish, I didn't load the game at all, but tried saving it again after and it corrupted the save.

So this shield crash is not caused by save/load, but it does break saving and loading.
+0 / -0