Loading...
  OR  Zero-K Name:    Password:   

ZK Lobby is unusable

21 posts, 579 views
Post comment
Filter:    Player:  
Page of 2 (21 records)
sort



RUrankFirepluk
29 days ago
(edited 29 days ago)

So I often alt-tab during games I spec...
When after say 5-15 min of innactivity in a lobby I come back I see EPIC HUGE LAG FEST
Even if the game has ended and I'm in the chat I can't do anything at all because lobby fast-forwards messages and other crap

This can last for minutes - lobby is totally unresponsive, so I'm better off killing process all together and restarting it...

edit: rage removed ^^
+1 / -0


DErankkatastrophe
29 days ago
(edited 29 days ago)

agree with the content
+0 / -0



AUrankAdminGoogleFrog
29 days ago
What content? We don't know if it was fine yesterday or three years ago.
+0 / -0



RUrankFirepluk
29 days ago
(edited 29 days ago)

It was fine before u made the change to lobby so it does not update UI while ingame and only when u switch to the lobby itself...
Even when it "worked as intended" it was clunky as hell... I wanted to kill the lobby and just restart as it was faster than all this jittering replaying which makes u want to scratch ur eyes out

If u wanna save on resources - update in one go instead of lazily replaying network messages u buffered... "pre-render" ur UI changes in memory to compute the final UI state and only then update. And make sure it does not block the lobby after 1 hour clusterfuck game finishes - it's gonna be A LOT of those changes and even pre-rendering in one go may not entirely save the situation here(probably tens of thousands of update state packets)

The best approach probably would be:
- if ingame/alt-tabed(minimized) do not update lobby from network packets - buffer instead
- when buffer size reaches N messages/game quits/maximized - recompute UI state in the memory, clear buffer
- when game quits - update UI in one go from memory state(no replaying)

No feature is better than crappy implemented feature.
Not sure even if we need this... what is the purpose?
+0 / -0


USrankFealthas
29 days ago
Can confirm, my ti-84 struggles to run chobby.
+0 / -0


CHrankConnetable
28 days ago
(edited 28 days ago)

When you say "it can last for minutes", seems like a huge overstatement. For me it's just a matter of seconds of wall of texts being uploaded and that's it.
+0 / -0

unknownrankHydris
28 days ago
I always get

[f=-000001] Error: [LuaMenu::RunCallInTraceback] error=4 (LUA_ERRMEM) callin=DrawScreen trace=[Internal Lua error: Call failure] not enough memory

And then the entire screen goes black and I can't see shit.

This is my toaster AMD FX-6350, AMD RX Vega 56, 8 GB RAM.
log: https://p.teknik.io/zB0JK

And yeah it's stupid slow if you tab out.
+1 / -0



RUrankFirepluk
28 days ago
(edited 28 days ago)

quote:

When you say "it can last for minutes", seems like a huge overstatement. For me it's just a matter of seconds of wall of texts being uploaded and that's it.

seems like u haven't spent 1 hour long games as spec being alt-tab most of the time
have fun next time u do

It's just disgusting to see the same ugly catch-up implemented in game being brought back to lobby
+0 / -0

NLrankmalric
28 days ago
The lobby IS using the same engine. So it was not re-implemented, it was easier to make like this. I agree it has downsides, but chobby is much better than most of the other lobbies I have seen...
+0 / -0



RUrankFirepluk
28 days ago
I don't really care what lobby is using
All I care is UX, and UX sucks so badly...
+0 / -0

unknownrankHydris
28 days ago
(edited 28 days ago)

quote:
The lobby IS using the same engine. So it was not re-implemented, it was easier to make like this. I agree it has downsides, but chobby is much better than most of the other lobbies I have seen...


This is the ONLY lobby where I had the problem of:

1. screen blacking out
2. having to restart the game
3. the lobby I was in started without me because to them I randomly left, and I can't explain either because I can't see the screen at all.

AND the added problem of unresponsiveness & resyncing.

log: https://p.teknik.io/r1gjv
+1 / -0

NLrankmalric
28 days ago
For 3 you mean "the battle I was in started without me because to them I randomly left, and I can't explain either because I can't see the screen at all."? And anyhow is this different than points 1 and 2?

It is a bit confusing because you mix problems (screen blacking out) with actions to fix them (restart the game) with things that happen to other players (games starts without you).

For Firepluk problem I think is clear and happens to me a bit when I return from the game, although I barely notice it (maybe stronger computer). What computer do you have Firepluk? Is it as bad when you finish a long game (for example due to messages in #zk channel)

+0 / -0




EErankAdminAnarchid
28 days ago
The back-processing thing could suspend rendering and notifications until it's done determining the final state.

E.g. if there's a notification of an instant match game becoming available then unavailable, it's not use showing it flicker on for a few milliseconds - just don't show it at all.
+1 / -0



RUrankFirepluk
28 days ago
quote:
For 3 you mean "the battle I was in started without me because to them I randomly left, and I can't explain either because I can't see the screen at all."? And anyhow is this different than points 1 and 2?

It is a bit confusing because you mix problems (screen blacking out) with actions to fix them (restart the game) with things that happen to other players (games starts without you).

For Firepluk problem I think is clear and happens to me a bit when I return from the game, although I barely notice it (maybe stronger computer). What computer do you have Firepluk? Is it as bad when you finish a long game (for example due to messages in #zk channel)

I'm playing from ultrabook(i7 7500u) with an external gtx 1060 connected via thunderbolt 3
Problem persist both when I come from long alt-tab while speccing and when I finish playing/speccing long match(~1h long or so)
+0 / -0

PTrankraaar
28 days ago
I haven't looked into it much, but it seems the zk lobby it often consumes 1 CPU core even while idle.
+1 / -0


USrankFealthas
28 days ago
PTrankraaar I have the same problem.
+0 / -0



CZrankAdminLicho
26 days ago
Is this the command buffering added to prevent ingame lags during peak times? Is it active when people alt tab out?
+1 / -0

NLrankmalric
26 days ago
For reference i have an i7-8700 with NVIDIA GTX 1060 6GB (normal desktop), and although I also see the described behavior, for me it takes couple of seconds (maybe 3-4 never counted). The processors does not seem that different compared to Firepluk's (even at 2x faster and it should be under 10 seconds).
+0 / -0


CHrankConnetable
25 days ago
Likewise for me. Firepluk's pc is full of worms i'm shure
+1 / -0

unknownrankHydris
23 days ago
It keeps happening.

log: https://p.teknik.io/8uHLT
+0 / -0
Page of 2 (21 records)