OR  Zero-K Name:    Password:   

Help make portable zip with spring engine for Linux

56 posts, 7256 views
Post comment
Filter:    Player:  
Page of 3 (56 records)
As you know Zero-K lobby supports multiple engine versions on windows and downloads them as needed.

We would like to achieve same on linux, however atm spring engine uses lots of .so dependencies.

If you want to help, we would like to test if such zip can be created and what libs must it include to work on most distros.

You can use something like

ldd /usr/games/spring | sed -rn "s/.*=> ([^ ]+).*/\1/p"


ldd /usr/games/spring | sed -rn "s/.*=> ([^ ]+).*/\1/p" | egrep -i "libboost|libfreetype|libpng|libstdc++"/usr/lib/x86_64-linux-gnu/libfreetype.so.6

to pick likely candidates.

Resulting spring binary + .so should be copied to machine without spring and tested.

If it works, automated script should be created for buildbot so that new engine versions are packed automatically.

It would be great if someone could help us test that out. None of the devs uses liunx.

If this works we can make ZKL work on linux and take advantage of this.

+0 / -0

7 years ago
Short list:


Long list:

+0 / -0
7 years ago
Would be nice to be able to install ZKL on USB drive/pendrive and have a portable
version with all maps, mods, widgets, configs, etc... in the pendrive.
So it can be used in any computer without leaving files in it (stealth: http://www.portablefreeware.com/faq.php#stealth ).

And if you include the Linux binary even better, so it work in Linux, Windows and maybe Mac? (never used Linux so no idea if that would work for Linux).
+0 / -0

7 years ago
Relevant perhaps:
Listed Dependencies (package names, not the files):

OS: Arch Linux, 64 bit

Short list:


Long list:

+0 / -0
7 years ago
Problem with Linux:
* No DL-engine-and-execute.zip
* NET-Framework and wine (runs windows stuff) can't handle most things which don't run under XP or do very deep system-calls.
+0 / -0

7 years ago
Gentoo ~amd64 with last emerge world done with a portage snapshot on ~ 2012-07-14.
$ uname -a
Linux dull 3.0.36-gentoo #2 SMP PREEMPT Fri Jul 13 13:11:00 MST 2012 x86_64 Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz GenuineIntel GNU/Linux

$ lsb_release -a
LSB Version: n/a
Distributor ID: Gentoo
Description: Gentoo Base System release 2.1
Release: 2.1
Codename: n/a

$ sudo emerge --info
Portage (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.0.36-gentoo x86_64)
System uname: Linux-3.0.36-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.1
Timestamp of tree: Sat, 14 Jul 2012 11:00:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.7 [enabled]
app-shells/bash: 4.2_p29
dev-java/java-config: 2.1.12
dev-lang/python: 2.7.3-r2, 3.2.3-r1
dev-util/ccache: 3.1.7
dev-util/cmake: 2.8.8-r3
dev-util/pkgconfig: 0.26
sys-apps/baselayout: 2.1-r1
sys-apps/openrc: 0.10.5
sys-apps/sandbox: 2.6
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.10.3, 1.11.6, 1.12.2
sys-devel/binutils: 2.22-r1
sys-devel/gcc: 4.6.3
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r3
sys-kernel/linux-headers: 3.4-r1 (virtual/os-headers)
sys-libs/glibc: 2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -mtune=native -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/bluetooth /etc/ca-certificates.conf /etc/dbus-1 /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/gtk-2.0 /etc/init.d /etc/kde /etc/mono /etc/pam.d /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/sound /etc/terminfo /etc/texmf /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev /etc/xdg /usr/share/X11/xkb /usr/share/texmf"
CXXFLAGS="-O2 -pipe"
EMERGE_DEFAULT_OPTS="--load-average=8 --jobs=32 --keep-going=y --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sfperms strict suidctl unknown-features-warn unmerge-logs unmerge-orphans userfetch usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X \ a52 aac aalib acl acpi alsa amd64 apache2 bash-completion berkdb bluetooth bzip2 cairo cdr cli cracklib crypt cups cxx dbus device-mapper dri dts dv dvd dvdr dvdread encode exif ffmpeg firefox flac fortran galago gdbm gdu gif glitz gmp gnome gpm graphviz gs gtk gtk2 howl iconv imap ipv6 jbig jpeg jpeg2k kpathsea kqemu lame lcms libnotify lzo matroska mbox mjpeg mmx mng modules mono mozilla mozsvg mp3 mplayer mudflap multilib ncurses nls nptl nptlonly nsplugin nvidia offensive ogg opengl openmp pam pcre pdf perl pic png policykit pppd pulseaudio python quicktime readline samba sdl session spell sse sse2 ssl static-libs subtitles svg sysfs tcpd theora tiff truetype udev unicode usb v4l v4l2 vcd vim-with-x vorbis win32codes wmf x264 xattr xcb xinerama xorg xv xvid xvmc zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias asis auth_digest autoindex cache dav deflate dir env expires headers include info log_config logio mime negotiation proxy rewrite setenvif speling status userdir usertrack auth_basic authn_alias authn_anon aut hn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfil e authz_host authz_owner authz_user cern_meta charset_lite dav_fs dav_lock dbd d isk_cache dumpio ext_filter file_cache filter ident imagemap log_forensic mem_ca che mime_magic proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http uniqu e_id version vhost_alias cgi" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_US" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia nv" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

$ ldd /usr/local/bin/spring | sed -rn "s/.*=> ([^ ]+).*/\1/p"
+0 / -0

7 years ago
Could some try copying those to separate folder, setting EXPORT LD_LIBRARY_PATH
and testing if it runs without installing spring/dependencies in system folders?

+0 / -0
If you do everything according instructions in spring engine page you can end up with ~/spring folder with engine which can run on most Linux systems. Problem is that it is ~150 Mb compressed. On my net it would take time to upload somewhere.

But I made multithreded version too.
+0 / -0
Anyone tried CDE? http://www.pgbovine.net/cde.html I once took amarok 1.4 from debian etch to debian squeeze. When I tried to take spring it took nvidia drivers and enough crap too so it didint worked on other pc. There even was thread on springforums about linux portable version but with no success nobody actually even wanted to test mine CDE package.

+0 / -0
7 years ago
I do not think that this is so important rly.
Spring homepage has nice instructions how to compile it. And you are rewarded with 64bit and multithreded version optimized for your CPU after completion much faster than multi-platform one.
+0 / -0

7 years ago
ProzacR what you mean - you have zip with 150mb that will run on most linuxes?

If it can be constructed automatically from built engine using ldd thats what we need.

Size is irrelevant, engine updates are very rare.
+0 / -0
7 years ago
I believe that if you do this on Linux:
git clone git://github.com/spring/spring.git -b master
cmake -DCMAKE_INSTALL_PREFIX=~/spring .
make spring-multithreaded
make install-spring-multithreaded
(This is rly all you need to download and install spring from source on Linux)
You get spring folder that can be runned on any Linux.

Of couse first you need all required libs installed or some .so will not be found.
+0 / -0

7 years ago
Yea, required libs and build dependencies. Cross distro, the library names in the packages can vary. This problem can be solved on a per-distro basis by having the appropriate packages as dependencies. However, having this spread to the distros will take time. I am assuming we want a faster solution than that, right?
+0 / -0
7 years ago
@wolas : It says: "Packages can range from 10 to 100 MB in size."

I rather want a step-by-step tutorial than auto-downloads of the engine...
Linux has no direct-X like windows (that is the only part I am sad about) and you don't want to lag the whole team (get kicked), do you?
* Cause if you only play single player, the version is irrelevant ^
+0 / -0
ProzacR we dont want that.

We dont want linux building

ZKL supports multiple engines at the same time, different room different engine.
And compiling takes time.

We need portable engine which we can download and stick to some folder.

It should be universal for as many linuxes as possible.
Those not supported will have to compile.

Per distro packages are too complex
+0 / -0
7 years ago
So type those commands I mentioned above compress with gzip or sth and distribute.
It should run on all Linux.
+0 / -0
7 years ago
If it would be so easy there wont be thread here.
+0 / -0
It is not easy it is very easy, hard part will be that 0k lobby needs microsoft stuff and microsoft do not make stuff for Linux they have their windows to sell.

Actually 0K runs fine on Linux as it is... and even better than on windows with 64bit and multithred support. Only you have to use SpringLobby not 0k lobby.
+0 / -0

7 years ago
So you tested it on other linuxes which didn't have spring installed ever?

On which distros?

ZKL does not need anything "microsoft" in fact it worked on linux and you can still grab older build.

Its just we didnt find any maintainer and all devs use windows. We still dont have any maintainer.
+0 / -0
7 years ago
Many games are distributed like that. If they do not run because there is no /lib/blabla.so in your Linux you get no blabala.so error then you can get blabla truogh package manager.

>ZKL does not need anything "microsoft"
It needs microsoft net framework check download page. ;)
microsoft net framework is obviously windows only by all possible means.

Oo Where I can get 0k lobby for Linux?
+0 / -0
Page of 3 (56 records)