Loading...
  OR  Zero-K Name:    Password:   

Zero-K and Video conflict? Full machine slow-down.

10 posts, 443 views
Post comment
Filter:    Player:  
sort
I like to listen to YouTube videos in the background as I play the game. The problem is that the whole machine grinds to a halt, even after I've stopped the video, closed the browser, quit Zero-K and Steam. As far as the game goes, it becomes very jumpy (is that frame-rate?) I can't scroll properly, every action is delayed by several seconds.

The only way to correct this is to restart my machine.


Is there a way to redress this situation?


Don't know if this is useful information.


System:

Kernel: 5.4.0-137-generic x86_64 bits: 64 compiler: gcc v: 9.4.0 Desktop: Cinnamon 5.0.7 wm: muffin dm: LightDM Distro: Linux Mint 20.2 Uma base: Ubuntu 20.04 focal


Machine:

Type: Desktop Mobo: ASUSTeK model: P8H61-M LE/CSM R2.0 v: Rev x.0x serial: <filter> BIOS: American Megatrends v: 1414 date: 09/23/2014


Battery:

Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325 serial: <filter> charge: 55% (should be ignored) status: Discharging


CPU:

Topology: Dual Core model: Intel Core i3-2100 bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB Speed: 1764 MHz min/max: 1600/3100 MHz Core speeds (MHz): 1: 1600 2: 1600 3: 1601 4: 1605


Graphics:

Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ASUSTeK driver: nvidia v: 470.161.03 bus ID: 01:00.0 chip ID: 10de:13c2 Display: x11 server: X.Org 1.20.13 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz OpenGL: renderer: NVIDIA GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 470.161.03 direct render: Yes


Audio:

Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 Device-2: NVIDIA GM204 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fbb Sound Server: ALSA v: k5.4.0-137-generic
+0 / -0
I don't see how much memory is in your system from the pasted information, but if it's lower than 8GB you might be running into some issues with swapping to disk. Your CPU also only has 2 real cores (4 thread) which could be borderline for running both the game and browser. It might be worth opening a terminal and running top in the background to see what's using your resources.

Can you play the game fine without YouTube running in the background?

Edit: Your GTX 970 should also support Nvidia drivers higher than the 470 series that is currently installed. You might be able to find a newer version in the mint Driver Manager.
+0 / -0

13 months ago
I had a similar issue trying to run 1440p resolution on a 4G (ATI) graphics card. Sometimes it was OK and sometimes it would bog down badly. Changing graphics settings to low didn't help, but stepping down to 1080p seems to have fixed it.
+0 / -0

13 months ago
quote:
even after I've stopped the video, closed the browser, quit Zero-K and Steam

Sounds like something hanging around in the background perhaps? If you get into this state, you could try checking with "top" or similar program if something is using all the CPU time. (or perhaps holding up all the RAM?)

Is this in a large-ish multiplayer battle or does it happen even in a 1v1 skirmish with AI?

YouTube videos in the background might still be using your GPU to decode the video. So I'd say it's (probably) better to listen to the music elsewhere while playing video games.
+0 / -0
CArankPorkchop: I've got 15 gigs of RAM. Normally, what sucks it up is Brave (Chromium-based browser) and Spring. Steam takes a gig of its own. Even if I quit Brave, Steam and Zero-K, if I relaunch Zero-K, it is slow to respond. It does seem like something hangs around, because it takes a reboot to smooth everything up again. Also, the drivers are those that come with my Linux Mint Updates.



ATrankfiendicus_prime: I'll see about dropping the resolution, as you've mentioned. I'll go hunt for it. In-game settings, or Steam?


NOranktalas: I only play 1 on 1 AI. "YouTube videos in the background might still be using your GPU to decode the video" I'll see if there's a way to do that. When I say "YouTube" what I really mean are podcasts, but they are usually on YouTube.


I've got a couple things to look into. If there's anything useful that I can append, let me know.


Thank you.
+0 / -0
13 months ago
I have noticed that if I click a link to the forum from the lobby I can't open the game up again
+0 / -0

13 months ago
CArankNotARealGamer I experienced some flakiness setting resolution in lobby. In the end it is easier to just change the Gnome system resolution (i.e. with Screen Display prefs) before playing and run full screen at whatever the system resolution is.
+0 / -0
quote:
I've got 15 gigs of RAM

How much VRAM tho? I tend to get issues on my poor 4GB GPU once i start having videos running in the background alongside cad software and 3d printer slicer software while also running ZK, and i think it's due to VRAM.
+0 / -0
13 months ago
EErankAdminAnarchid I've got 4gigs of VRAM. My machine is not bad, but I try to not overload it for simple and practical reasons. I do notice that the lobby is slow, too.

I've found an extension for Brave that will download YouTube but spit off the video from the audio. Same results. I've played with turning Brave's "use GPU rendering" on and off. Seems to have no impact.

If I've gotten a slow down once, I can quit every program and (almost) every background service (I'm on Linux, BTW) and the issue remains.

I do notice that steam on its own gobbles up 5gigs of RAM.
+0 / -0
Just a note for the devs and more experienced people.

I've found the cause to Zero-K / YouTube slow-down conflict. As soon as I turned shadows completely off on Zero-K, everything became quick, smooth and snappy, everything else is still set at Ultra. I can now listen to speeches and podcasts while playing Zero-K.

EErankAdminAnarchid
+1 / -0