Loading...
  OR  Zero-K Name:    Password:   

Linux load times + performance unplayable

58 posts, 1372 views
Post comment
Filter:    Player:  
Page of 3 (58 records)
sort
14 months ago
I've been playing Zero-k for a little while now, and I've noticed that when I launch on Windows I get solid performance on High graphics. I have no trouble playing in cluster matches (except for times when it gets real ridiculous >10v10 with lots of tremors etc). Load time is somewhere around 10 seconds for a match.

Yet linux, which is my preferred operating system, is an entirely different story. Load times are often up to and over a minute. People regularly force start a game before my client loads, which ruins a game experience when you can't choose where your commander is. Yet my linux nvme SSD is much faster than my windows SSD and that shows in other write intensive aspects.

Furthermore, the SIM engine seems to be significantly slower on linux. Large cluster matches are unplayable. Any game with 10 or more players (>5v5) is not worth joining because I will lag out and be unable to play. Even with lowest graphics. WITH LOWEST GRAPHICS. This is a fairly modern mid-high end system.

I do not think this discrepancy is due to drivers. I run other games that load as fast in linux (Company of Heroes (1+2), Xonotic, Doom 2016) as in Windows. I get around 10% less FPS in linux than windows for the listed games, but not nearly the order of 1/2 to 1/3 that I see in Zero-K.

So my question is to the devs, where do I start troubleshooting this? The first step seems to me to grab benchmarks that show SIM/DRAW fps in both linux and windows in similar matches.

Systems Specs for the curious:

quote:

System: Host: azimuth Kernel: 4.18.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 8.2.1
Desktop: KDE Plasma 5.13.5 Distro: Arch Linux
Machine: Type: Desktop Mobo: ASRock model: X370 Gaming-ITX/ac
UEFI: American Megatrends v: P4.50 date: 02/12/2018
CPU: Topology: 8-Core model: AMD Ryzen 7 1700X bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 108642
Speed: 2706 MHz min/max: N/A Core speeds (MHz): 1: 2706 2: 2718 3: 2719 4: 2721 5: 2721 6: 2725
7: 2722 8: 2723 9: 2721 10: 2723 11: 2720 12: 2960 13: 2718 14: 2722 15: 2716 16: 2722
Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Vega 10 XT [Radeon RX Vega 64] driver: amdgpu v: kernel
bus ID: 28:00.0
Display: x11 server: X.Org 1.20.1 driver: amdgpu unloaded: modesetting resolution: 2560x1440~60Hz
OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.26.0 4.18.9-zen1-1-zen LLVM 6.0.1) v: 4.5 Mesa 18.2.0
direct render: Yes
Drives: Local Storage: total: 6.37 TiB used: 1.89 TiB (29.6%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 500GB size: 465.76 GiB
ID-2: /dev/sda vendor: Hitachi model: HUS724030ALE641 size: 2.73 TiB
ID-3: /dev/sdb vendor: Crucial model: CT500MX200SSD1 size: 465.76 GiB
ID-4: /dev/sdc vendor: Hitachi model: HUS724030ALE641 size: 2.73 TiB
Partition: ID-1: / size: 425.46 GiB used: 216.07 GiB (50.8%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /boot size: 511.0 MiB used: 125.8 MiB (24.6%) fs: vfat dev: /dev/nvme0n1p1
ID-3: swap-1 size: 32.00 GiB used: 256 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3
Info: Processes: 366 Uptime: 5h 41m Memory: 15.60 GiB used: 4.46 GiB (28.6%) Init: systemd Compilers:
gcc: 8.2.1 clang: 6.0.1 Shell: zsh v: 5.6.2 inxi: 3.0.20


This is a major block for me and makes zero-k unplayable. 90% of games seem to always just be a large cluster match. I cannot join them because of my system. I know it is a meme that Zero-K is not meant to be played, but unless we can see decent performance fixes, it might really not be for me.
+1 / -0
main things with linux are driver issues

1 do you have all the most correct propriety drivers for graphics / chips ? .. you say its not drivers but you need to be sure

2 whats your internet speed like?

3 do you lag lategame heaps more then earlygame?

4 do you lag allot at start of battle?
+0 / -0


14 months ago
Why use driver amdgpu? Have you tried mesa?
+0 / -0
I'm on Linux but with nVidia. Desktop machine with spinning disk loads games slowly, but once I get in game, it's fast.
Laptop with nVidia PRIME is good on Ubuntu. Hits slowdowns in large matches, but playable. I don't use Windows so I can't compare the performance; I do have a windows partition on the laptop.

We used to run this benchmarker long time ago:
https://springrts.com/phpbb/viewtopic.php?t=30397
I wonder if it still works.

I also see that version 17.30 of the AMDGPU-PRO driver is the first one that supports your card, which version do you have?
+0 / -0
AUrankSmokeDragon

1. How can I be sure that its not a driver issue? I'm running latest MESA/AMDGPU. My driver is newer than the build. I have no issues with other games. Xonotic for instance runs at 250 FPS on max.

2. Internet speed: ~90/5 Mbps Down/Up.

3. Early game isn't an issue. It doesn't become a problem until significant amounts of units have been produced. Usually I don't get my units turned over until flea spams or tremors come out.

4. I don't lag at the start of battles.


CArankTheMooseIsLoose

You can probably check my understanding, but AMDGPU is part of MESA. I am using the latest MESA available for me. To clarify I am not using the proprietary AMDGPU Pro drivers which are distributed via binary bundle.

FIrankVermind

I am not running AMDGPU Pro, but the opensource stack in the kernel: AMDGPU.

Looking at that benchmark link, I can't seem to find the source code for it. It links to a dead google code page. There is a binary that works with mono, but segfaults instantly when a button is pressed. Looking for the code on the github, I noticed https://github.com/ZeroK-RTS/Benchmarks. Can AUrankAdminGoogleFrog give any hints here?
+1 / -0
Here it seems Mesa 18 is even better than binary-blob amdgpu-pro:

These results also seem to suggest that:
https://www.phoronix.com/scan.php?page=article&item=radeon-soft-1810&num=1

You are using a higher resolution than me and probably higher settings.
Can you link to a replay and say where it gets slow for you so I can try?

Also in Multiplayer B616755 5 on Mearth_v4 you mention having a black map, this should only happen if you don't have libtxc-dxtn-s2tc0 or s3tc installed, and so cannot get texture compression working in MESA.
+1 / -0


14 months ago
Maerth is a broken map. Nothing to do with any driver problems.
+0 / -0
14 months ago
Hmm. It looks like libtxc_dxtn was removed.

https://lists.freedesktop.org/archives/mesa-dev/2017-October/171265.html
https://bugs.archlinux.org/task/56660

As far as a replay that dies:

https://zero-k.info/Battles/Detail/615293 - speedmetal

I need to look for my larger games. There were a couple really awful ones that I wasn't able to finish.
+0 / -0

14 months ago
Cool about libtxc_dxtn being integrated to mesa, didn't know that.

The replay you linked seems to have sync errors for you, and I get sync errors also viewing it. Infolog:
https://pastebin.com/6LhTqYsq

This is an engine bug and should be reported.

The replay also crashes spring on my computer at about 57%.
+0 / -0
Very slow too. 10 vs 10 not playable after 10 min/ it depends of unit count I think.

proc: AMD 8 cores
RAM: 8GB
video: GTX 650
ethernet: 100MBit/s

+0 / -0

10 months ago
RUrankalexey2baranov what driver are you using?
+0 / -0
Same story - been playing from linux with proprietary nvidia drivers for a while...
ZK is significantly slower - loads slower, less peak fps, gets slowed down faster, weird stutters mid-late game
It gets -very- bad in big matches when people start to abuse flea/puppies, to a point where I get below 1 FPS - game just freezes for seconds, can't do anything at all...

On windows it plays much better using exactly the same HW.
Kind of gave up... thinking of going back to windows

My setup is quite unusual though - notebook(16gm ram, i7 7500u) with external GPU(gtx 1060) via thunderbolt 3 interface
But I doubt there is a problem here - all other games work fine
+0 / -0

10 months ago
I cannot confirm that ZeroK runs slow under Linux at times of my smurfy days I ran two ZK instances at same time.
I have nvidia though and Intel i7

USrankatraii post your Xorg.0.log after starting X-windowsystem

+0 / -0
10 months ago
USrankOflameo see my screenshot/ i use video-nvidia-390 (proprietary nvidia driver)
+0 / -0
I don't think I have these problems.
So, im spectating a full ~30 player game right now, 20 minutes in.
Map load time from cold start 18 sec. HDD with bcache.
Got 11 - 15 fps depending on zoom. 3.9 GB ram and 120% CPU used by game.
Amd fx-6350 CArank4.5GHz with 4.7GHz turbo.
Rx 480 and stable mesa drivers.

I have not used Windows for past 18 years so I don't know what performance to expect.
+0 / -0
10 months ago
by the way what does "compat." graphic preset mean?
+0 / -0


10 months ago
compatibility obviously
+0 / -0
10 months ago
с чем совместимость?
GPU don't use in compat mode?
+0 / -0
10 months ago
one more question. what does "Catching Up, ETA:" mean into game?
+0 / -0
it means you are behind in what's going on in game and you have to "catch up"
ETA - estimated time to complete this process
+0 / -0
Page of 3 (58 records)