Loading...
  OR  Zero-K Name:    Password:   

Unable to open game since update

14 posts, 336 views
Post comment
Filter:    Player:  
sort

USrankGRATS
3 months ago
(Linux 64 bit)
Since the night 2 nights ago that the spring engine was updated and had an error so it was reverted, ever since then when I run "mono zero-k.exe" it crashes at "querying default engine"
Zero-K.exe Information: 0 : Checking for self-upgrade
Zero-K.exe Information: 0 : Querying default engine

I've done:
rm -R *
wget http://zero-k.info/lobby/Zero-K.exe && mono Zero-K.exe

multiple times, this works. and it redownloads everything obviously, and then the game works fine. as soon as I exit I can never open it again...
Is there something specific I can delete to get it to open again or..?
I've also ran it as root..
Any logs that will help?
+2 / -0

USrankGRATS
3 months ago
(edited 53 days ago)

https://pastebin.com/1S1GhA8Q

(Pastebinned by MYrankAdminHistidine)
+0 / -0



AUrankAdminGoogleFrog
3 months ago
When is the crash? That looks like it launches.
+0 / -0

USrankGRATS
3 months ago
Yea it doesn't crash, it just sits there, forever. (Let it run for 3 hours) it has the loading bar of the game "update/download" I haven't been able to get it to go past that unless I delete everything.
+0 / -0


USrank_Shaman
3 months ago
Next time please use pastebin or something similar.
+0 / -0

USrankGRATS
3 months ago
Alright sorry. If someone wants to see it hang you can connect to me via teamviewer?
Is it possible it's related to mono version update?
+0 / -0



AUrankAdminGoogleFrog
3 months ago
A mono change could definitely break the launcher.
+0 / -0

USrankGRATS
3 months ago
This is the version:
Mono JIT compiler version 5.18.0.198 (tarball Wed Nov 14 08:59:10 UTC 2018)

That's the compile date but I'm assuming my system just updated it 2 days ago or something. This Desktop is ubuntu based so I don't really pay attention to the updates since it isn't LFS or Gentoo.

What is weird is it works fine when it's first installed, but then it doesn't work after that.
+0 / -0

USrankPhytophyte
3 months ago
I've been dealing with this for about a month now. I've managed to narrow down the issue to something in Zero-K's game folder. If you delete the "games" folder from your Zero-K directory, the game should launch normally after downloading just that.

You can streamline this by changing your Zero-K launch command to:
rm -r (path to Zero-K Directory)/games && mono (path to Zero-K Directory)/Zero-K.exe


quote:
When is the crash? That looks like it launches.

I've tested it by deleting the infolog before allowing Zero-K to freeze. A new infolog does not generate, so it's locking up before that.

GRAT's infolog is likely from a previous successful launch.
+2 / -0

USrankGRATS
3 months ago
(edited 3 months ago)

Oh yea I guess my info log was from a previous launch. I've reproduced what you have (deleting the games folder and then launching) works fine..
What version of mono do you have?

I was actually in the middle of deleting each individual file / folder and trying to run it each time lol. Was about 10 files in and I refreshed and just saw your post.

du -sh games/
510M games/

I guess it depends on your internet, but I have 1gbps connection so it isn't much to DL each time I play, but it isn't great for the servers either.

Is there a way to get more debug from the game?

zerok> ls -thal games/
total 510M
drwxrwxrwx 21 grats grats 4.0K Nov 22 22:56 ../
drwxrwxr-x 2 grats grats 4.0K Nov 22 22:55 ./
-rw-rw-r-- 1 grats grats 4.3K Nov 22 22:55 zerokBenchmark02.sdz
-rw-rw-r-- 1 grats grats 359M Nov 22 22:55 39d82368167c5ae54652065fe37d5445.sdz
-rw-rw-r-- 1 grats grats 2.3M Nov 22 22:54 seeker.sdz
-rw-rw-r-- 1 grats grats 179K Nov 22 22:54 quicktutorial.sdz
-rw-rw-r-- 1 grats grats 149M Nov 22 22:53 243da99b9f102a866c4b6c7bd4ce8ff1.sdz

Looks like all you need to delete is this specific file:
rm games/39d82368167c5ae54652065fe37d5445.sdz
I tried each file individually and that one is all that is needed and the game boots fine
+0 / -0

CHrankcoppaMan
3 months ago
(edited 3 months ago)

I had the same issue with the Windows binary from the Zero-K main site and the Linux binary from itch.io. The first start always works perfectly fine but the launcher gets stuck at "Querying default engine" when I try to open it afterwards.

Someone then suggested to me to try the steam version by running Zero-K.sh in steamapps/common/Zero-K dir. So you need to download Zero-K through steam running in wine or you can ask for a Linux key for a version on steam running on Linux.

I had 0 problems since then.
+1 / -0

USrankGRATS
3 months ago
Yep I just got a linux beta key for steam and it works great now. Thanks!
+2 / -0

SEranksnubbe
2 months ago
This problem still isn't fixed. I got exactly same problem.
Last message in terminal window is "querying default engine" and then the "Zero-K is updating, please wait" window just hang there unresponsive.
A clean install or deleteing files in games/ folder makes it download stuff and start.

Running through steam also works but needing to start steam adds to loading time.
+0 / -0

SEranksnubbe
54 days ago
Come on! Grow a beard!! Fix it!
+1 / -1