Loading...
  OR  Zero-K Name:    Password:   

Unable to start single-player level while not connected to Internet

16 posts, 413 views
Post comment
Filter:    Player:  
sort
6 months ago
After the most recent update, if I am not connected to the Internet, then when I start a single-player mission, I am presented with a blank level with no units or buildings, and a yellow button labeled "Ready". The only thing that happens when I click that button is that it disappears. Game time counts forward, and I can pause normally, but no units or buildings are visible or selectable.
+0 / -0


6 months ago
Can you check the integrity of your install? It sounds like it is trying to use an old game version on a new engine.
+0 / -0
6 months ago
Hello I installed the game yesterday on a laptop running Ubuntu (Linux) using the instructions in the wiki of this website and I have exactly the same problem. When the game is ready, there is nothing but the map, not even the green areas to start whereveryou want and I don't have the commander menu....(tested yesterday night)
If it's an old version which one is the new one?
Thank you for your help :)
+0 / -0
The itch.io version of ZK hasn't been updated yet (but it will be within an hour or so).

EDIT: Should be done now.
+2 / -0
6 months ago
Thanks I will try to reinstall and provide feedback
+0 / -0
6 months ago
Hello, it still doesn't work, no menu visible etc, only I've got the com this time and could play (move the com only)
+0 / -0


6 months ago
Reproduce the bug, then without closing the lobby, submit a report. Link the report here.

+0 / -0
6 months ago
I just noticed I posted my reply in the wrong browser tab. Sorry, meant to post it here. Apologies about the re-post:

I am having the same problem. I just submitted a bug report, but I had some more potentially relevant details.

I wanted to add that I have tried uninstalling and reinstalling Zero-k via Steam client. Problem persisted. Tried verifying file integrity: reports 2 files are bad and will be reacquired. It does so, or does something anyway since a second check of the files finds nothing. Launch game; attempt to start a campaign level or skirmish; problem persists. Close game; check files again; 2 bad files found; rinse and repeat. Still happening 3 tries later.
+0 / -0


6 months ago
It should be fixed now. We think that something within the Spring engine infrastructure broke the incremental game updater, so the correct version could not be fetched. Singleplayer did not know which version to run so it defaulted to a two year old version of Zero-K. This version is unable to run correctly on the latest engine version.
+1 / -0
This makes sense, I will try tonight, do it will be updated automatically?
thank you again
+0 / -0


6 months ago
It is, it is a steam update.
+0 / -0
6 months ago
Even when you didn't install the game via steam?
+0 / -0


6 months ago
Probably? If you see "updating zkmenu:stable" then it should be able to get the latest version.
+0 / -0
6 months ago
Yes, then I guess it will work, thank you very much for fixing this.
+0 / -0
6 months ago
My entire ZK doesn't want to start. It tried to update, couldn't and now it says "this app won't run on your PC"

Do I need to reinstall everything again?

I can't even remember where I got the original files :O
+0 / -0
6 months ago
This appears fixed after another update. Thank you very much! That's a relief, since I always play offline (so far).
+0 / -0