Loading...
  OR  Zero-K Name:    Password:   

Custom AI's

9 posts, 259 views
Post comment
Filter:    Player:  
sort
So, I was trying to create a custom AI (built off of the brutal) ,but when I go to add it I can't see it. I already have unchecked the "Simplified AI list" box. Is there anything else I need to do?
+2 / -0


9 days ago
Describe what you have actually done so far in as much detail as possible, because otherwise it is infeasible to gueass what you missed.
+0 / -0
9 days ago
Well, I navigated to the AI directory, and copied the brutal files. Most of what I did was edit the JSON files located in config. Although, I did edit the ones outside of the config folder (I just changed the name of the AI). I then opened the game unchecked the Simplified AI list box, but I still couldn't see it in the AI list.
+0 / -0
Did you edit the AIInfo.lua file?

quote:
I then opened the game unchecked the Simplified AI list box, but I still couldn't see it in the AI list.

I think you may have to restart after unchecking that.
+0 / -0
9 days ago
Yeah I did edit that file. Hmm, I haven't tried that.
+0 / -0


9 days ago
quote:
Yeah I did edit that file.

In case restart doesn't help, you could trawl the diagnostic log for any mentions of either the folder name you gave to your copy, or the name you gave to the ai in aiinfo.lua.

Your process worked for me, so it should work for you - unless it's either not loaded because it needs a restart, or because engine refuses to consider it a valid entry for some reason.

Possibly you could have also made an error when editing the aiinfo.lua, like forgetting a comma, a brace, or a quote somewhere, making the file invalid.
+2 / -0
9 days ago
Thanks for the help. I was finally able to see it listed with the other AI's. The problem was that I didn't put the AI files in a directory called stable.

Is there a way I can close my post?
+1 / -0
I think if you edit the OP you can change the title to e.g. have [SOLVED] in it.
+1 / -0
So when I went to go test the AI this morning. It errored saying the name of the log script in the main directory. When opened the file it said that the config file didn't exist. What am I doing wrong?
+0 / -0