OR  Zero-K Name:    Password:   

Im offended by zk linux installer

7 posts, 215 views
Post comment
Filter:    Player:  
12 days ago
i tried to install zk on linux and it said this to me:

bodhi@bodhi:~/chobby$ ./Zero-K.exe
Zero-K.exe Warning: 0 : PackageDownloader : File don't exist : /home/bodhi/chobby/cache/repositories.json
Zero-K.exe Information: 0 : Trying to start with GUI
Zero-K.exe Information: 0 : Checking for self-upgrade
Zero-K.exe Information: 0 : PackageRefresh complete - packages changed
Zero-K.exe Information: 0 : https://repos.springrts.com/zkmenu/packages/611133fb90ac808556cc842cf786dc45.sdp Completed - 81.13k
Zero-K.exe Information: 0 : zkmenu:stable download complete - 167.68M
Zero-K.exe Error: 0 : https://repos.springrts.com/zk/packages/f5cf9b7e7380bf8b22246d24c5db5be8.sdp failed System.Net.WebException: Error: TrustFailure (Authentication failed, see inner exception.) ---> System.Security.Authentication.AuthenticationException: Authentication failed, see inner exception. ---> Mono.Btls.MonoBtlsException: Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED
at /build/mono-L7Ktbc/mono-
at Mono.Btls.MonoBtlsContext.ProcessHandshake () [0x00064] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake (Mono.Net.Security.AsyncOperationStatus status, System.Boolean renegotiate) [0x00106] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at (wrapper remoting-invoke-with-check) Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake(Mono.Net.Security.AsyncOperationStatus,bool)
at Mono.Net.Security.AsyncHandshakeRequest.Run (Mono.Net.Security.AsyncOperationStatus status) [0x00006] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at Mono.Net.Security.AsyncProtocolRequest.ProcessOperation (System.Threading.CancellationToken cancellationToken) [0x0012a] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
--- End of inner exception stack trace ---
at Mono.Net.Security.MobileAuthenticatedStream.ProcessAuthentication (System.Boolean runSynchronously, Mono.Net.Security.MonoSslAuthenticationOptions options, System.Threading.CancellationToken cancellationToken) [0x00346] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at Mono.Net.Security.MonoTlsStream.CreateStream (System.Net.WebConnectionTunnel tunnel, System.Threading.CancellationToken cancellationToken) [0x001f4] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at System.Net.WebConnection.CreateStream (System.Net.WebOperation operation, System.Boolean reused, System.Threading.CancellationToken cancellationToken) [0x001f5] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
--- End of inner exception stack trace ---
at System.Net.WebConnection.CreateStream (System.Net.WebOperation operation, System.Boolean reused, System.Threading.CancellationToken cancellationToken) [0x00275] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at System.Net.WebConnection.InitConnection (System.Net.WebOperation operation, System.Threading.CancellationToken cancellationToken) [0x0015b] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at System.Net.WebOperation.Run () [0x000b7] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at System.Net.WebCompletionSource`1[T].WaitForCompletion () [0x000b1] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at System.Net.HttpWebRequest.RunWithTimeoutWorker[T] (System.Threading.Tasks.Task`1[TResult] workerTask, System.Int32 timeout, System.Action abort, System.Func`1[TResult] aborted, System.Threading.CancellationTokenSource cts) [0x00118] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00025] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at System.Net.WebClient.GetWebResponse (System.Net.WebRequest request, System.IAsyncResult result) [0x00000] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at System.Net.WebClient.GetWebResponseTaskAsync (System.Net.WebRequest request) [0x0009e] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
at System.Net.WebClient.DownloadBitsAsync (System.Net.WebRequest request, System.IO.Stream writeStream, System.ComponentModel.AsyncOperation asyncOp, System.Action`3[T1,T2,T3] completionDelegate) [0x0009e] in <a85c1a570f9a4f9f9c3d2cfa5504e34f>:0
Zero-K.exe Error: 0 : Error downloading zk:stable System.ApplicationException: FileList has download failed
at PlasmaDownloader.Packages.PackageDownload.GetFileList () [0x0009a] in <b4b02ccc8a924170abf5c2abfc770f2f>:0
at PlasmaDownloader.Packages.PackageDownload.MasterDownloadThread () [0x00162] in <b4b02ccc8a924170abf5c2abfc770f2f>:0

im offended... any clue what gives? expired ssl certs or something,,, idk.
+2 / -0
11 days ago
bump. still no clue why installer on linux beeps those ssl certs no bueno messages
+1 / -0

11 days ago
Have you installed the dependencies mentioned in itch.io?
+0 / -0
11 days ago
Yea, almost 300megs o them, also i did netlink to other puter via sshfs to see if old zk install that i was using there would chooch (box got guttered of gpu and other goodies), it didnt.
+0 / -0

10 days ago
Here are some troubleshooting steps that may help:

+0 / -0
Is it an older Zero-K.exe file, or the newest one from https://zero-k.info/Lobby/Zero-K.exe ? What linux distro are you running it on?
+0 / -0
10 days ago
both on older and freshly wgeted. i have old hdd with prev install as well. distro is bodhi running live atm, maybe its the problem so it has stale ssh thingies. the thing ILrankrollmops mentioned looks promising

btw, anyone has like spare sata 2 500gig hdd? it might have bad sectors i need it for like couple hours run time to plop whole hdd of lappy to it and back (lappy is in some voodoo intel managment of satas so linux installer says no buyeno, and solution is to dd whole thing, change it in bios and dd it back), i doubt that more bad sectors happen in that time.
+0 / -0