OR  Zero-K Name:    Password:   

HELP! Zero-K (using Chobby) unusable in Linux

71 posts, 2177 views
Post comment
Filter:    Player:  
Page of 4 (71 records)
I am rather frustrated at the moment as Zero-K now consistently grinds my computer to a halt, and I have to push the reset button, under linux on the second loading of the game.

Don't know if this is relevant:

Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: Zero-K.exe Error: 0 : Error reading version list from http://tadrd.repo.springrts.com: System.Net.WebException: Error getting response stream (ReadDo
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at System.Net.WebConnection.ReadDone (System.IAsyncResult result) [0x00000] in <2fef7234205a4a009fe5995569c314ee>:0
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at System.Net.Sockets.SocketAsyncResult+<>c__DisplayClass27_0.<Complete>b__0 (System.Object _) [0x00000] in <2fef7234205a4a009fe5995569c314ee>:0
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem () [0x00000] in <73ee1b14c2fa4d61b481096ff3d8d6d
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at System.Threading.ThreadPoolWorkQueue.Dispatch () [0x00000] in <73ee1b14c2fa4d61b481096ff3d8d6d7>:0
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback () [0x00000] in <73ee1b14c2fa4d61b481096ff3d8d6d7>:0
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at System.Net.WebConnection.HandleError (System.Net.WebExceptionStatus st, System.Exception e, System.String where) [0x0003b] in <2fef7234205a4a009
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: --- End of inner exception stack trace ---
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00058] in <2fef7234205a4a009fe5995569c314ee>:0
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at System.Net.HttpWebRequest.GetResponse () [0x0000e] in <2fef7234205a4a009fe5995569c314ee>:0
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at ZkData.Utils.DownloadFile (System.String url, System.Nullable`1[T] ifModifiedSince) [0x000c7] in <fc637dbccd864faab05afa4f81da8d82>:0
Jan 02 19:19:19 light0 menulibre-new-launcher.desktop[23698]: at PlasmaDownloader.Packages.PackageDownloader+Repository+<>c__DisplayClass16_0.<Refresh>b__0 () [0x0002b] in <fc637dbccd864faab05afa4f81da8d82>:0
+0 / -0

2 years ago
we just compared the ram values on (battle follows).
Firepluk said he has only 1.5 GB on win while me and Lynx having around 5 GB on RAM usage for spring. Can anyone explain that?
+0 / -0
Window's task manager shows 1.2gb - 2gb on various battles, never seen over 2gb in win...
But this is probably because chobby still downloads 32bit spring on windows, does it?
A year ago or so I remember manually checking 64bit build for windows - it worked perfectly and afaik I even had slightly higher fps
+0 / -0
Look at this memory usage right after I got the usual loading JAM: 6GB RAM + 2GB SWAP

free -mh:

total used free shared buff/cache available
Mem: 7.7G 7.4G 125M 75M 217M 68M
Swap: 20G 2.3G 17G

.. and here is the first two lines of 'top' after a while:

4019 - 20 0 14.154g 5.962g 107.9 77.0 77:02.23 R spring-main
1687 - 20 0 4153.1m 309.8m 19.2 3.9 3:24.09 S gnome-shell

see here: http://mugurel.sumanariu.ro/linux/the-difference-among-virt-res-and-shr-in-top-output/

Memory leak?
+0 / -0

2 years ago
Just did a small test on Linux:

after starting chobby spring already needs 1.5GB
after joining a 11v11 game (5 minutes into the game) the memory consumption is at 6GB
after leaving the game and returning to lobby (via lobby -> leave): still at 6GB
after rejoining the same game: 8GB
after rejoining the same game a third time: 10GB

+2 / -0

2 years ago
I am not using chobby and do not have this "memory-stays"-issue.
It is like 4.5 GB mem-usage in average for clustergame. When I close spring those are free'ed. Starting spring again adds those 4.5 GB :-)
Maybe it is chobby related.
+1 / -0
Just tried using flobby-git Archlinux package and I see zero issues.
+0 / -0
I think you would be best off with a mantis report https://springrts.com/mantis as I would only be ferrying responses between those two areas. Another option is to ask on the spring forums https://springrts.com/phpbb/viewforum.php?f=20 .
+1 / -0
2 years ago
The engine is currently leaking tons of memory, I have noticed that too. I just couldn't be bothered to do a bugreport yet.
+1 / -0

2 years ago
Any way to use /debug while the game is running to see what the memory is being used on?
(Hint: Try it)
+0 / -0
2 years ago
About the 5GB on Linux vs 1.5GB on Windows:
64-bit spring default to using the fairly new LuaMemPool (adds ~2.3GB mem usage for me) which seem to be an attempt to avoid OOM issues reported by zk players, see https://springrts.com/phpbb/viewtopic.php?p=582590#p582590 .
Also, 32-bit spring will use less memory than 64-bit spring even with this mempool disabled (UseLuaMemPools = 0).

I find it a bit odd that the zk OOM issues can be resolved by this since the mempool is likely disabled for all windows zk players running 32-bit spring, perhaps someone(hokomoko?) can explain this though.
+1 / -0

2 years ago
JPrankgajop: where does it show the memory consumption with /debug? All I can see is that drawing takes a lot of time. Oh, and Lua-allocated memory is at 204.8MB.
+0 / -0
To be clear here, is the issue that Chobby is setting up a 64-bit instance of spring, which is failing, whereas flobby is setting up a 32-bit instance of spring, which is not failing? If so, why does flobby get a 32-bit rather than 64-bit version? If not, then why is running Zero-K under Chobby but not flobby failing?
+0 / -0

2 years ago
Try running chobby with 32 bit spring and see what happens.
+0 / -0
2 years ago
I have also had problems with colossal huge amount of ram being used, 8 GB in computer not enough.

Did some testing now while monitoring ram usage via top (ssh app on phone).
~1,5 gigabyte ram used just entering the lobby.
Spectating some online speedmetal, fast forward 14 minutes into game, < 3.5 gigabyte ram used.
Then a new 2 player game on same map, with few units. Same amount of ram.
Then some single player, about the same gigabytes used.
And finally a chicken game started at over 3 gigabyte and ended below 3 somehow after a while.

So whatever made it use super large amount of ram before seems to be solved. (?)
+0 / -0
Sounds like 64bit engine to me.
If there is a difference with flobby, it might also be something in spring configuration (you can copy the one from flobby to the Chobby)
+0 / -0
Just noticed that flobby appears to be obtaining and presumably using the 64-bit version of spring:


I copied over springsettings.cfg from Chobby to flobby so it cannot be that. What other files should I be looking at?

+0 / -0
2 years ago
Lynx, if you only have 7.7GB and running 64-bit spring you should try "UseLuaMemPools = 0" to reduce mem usage.
+0 / -0
Who is having 8 GB of ram in 2018? -facepalm-
Upgrade this shit!
+0 / -0

2 years ago
chobby with "UseLuaMemPools = 0":
start: 1.5GB
1st game: 3GB
2nd game: 3.25GB
3rd game: 3.5GB

chobby with default value ("UseLuaMemPools = 1"?):
start: 1.5GB
1st game: 6GB
2nd game: 8GB
3rd game: 10GB
+10 / -0
Page of 4 (71 records)