Anarchid's point that using force prefix would be ambiguous is a good point.
Just let me point a few things, to demonstrate that confusion is probably a design goal, or that its just the result of lack of design leading to absence of consistency and thus confusion.
quote:
public void ComForce(TasSayEventArgs e, string[] words) { if (spring.IsRunning) { SayBattle("forcing game start by " + e.UserName); spring.ForceStart(); } else Respond(e, "cannot force, game not started"); }
|
And:
quote:
public void ComForceStart(TasSayEventArgs e, string[] words) { ... tas.StartGame(); ... }
|
If you didn't understand the code, it means:
- force is a command that does a forcestart
- forcestart is a command that does start the game
So yes, adding various "force" prefixed commands is probably adding more confusion if nothing else is changed. Or, now is a good time to actually make things logical...
(sorry for the bad code formatting, this Forum Done Right (TM) is missing a few features. But we have avatars, so who cares about code formatting?)