Loading...
  OR  Zero-K Name:    Password:   

Forum index  > News   >

Zero-K v1.10.11.3 - Factory Loitering and Engine Update

19 posts, 2298 views
Post comment
Filter:    Player:  
sort


12 months ago

We have been testing an engine update since Wednesday, and this time it seems stable enough to adopt. The update corresponds to about ten months of work and mostly involves the graphics backend. As a result, performance has improved for many people and some AMD graphics issues have been fixed, although in testing we found the current beta graphics drivers to be unreliable. Be sure to ask on the forums or Discord if you encounter issues. The engine also has a few new features, with the biggest being the ability to shrink the space factories try to clear of allied units. The update also has some new music tracks from Superintendent and the commander morph rate nerf has been reduced.

Balance


Commander upgrade has its recent nerfs reduced, particularly at high levels.
  • Morph rate 5/5/7.5/7.5/10/10/10... -> 5/7.5/10/12.5/15/15/15... per level

Features


  • Performance should be improved for many people.
  • Allied units can loiter much closer to factories without being told to go away.
  • The auto assist toggle sends constructors directly sideways, to save time.
  • Added more tracks by Superintendent.
  • Show Selection Rank by default.
  • Improve RoI tracker and add a hotkey to toggled it.
+10 / -0

12 months ago
Awesome!
+0 / -0

12 months ago
quote:
Morph rate 5/5/7.5/7.5/10/10/10... -> 5/7.5/10/12.5/15/15/15... per level

Not much but at least now it won't take 2-3 minutes to just morph 3 basic modules.
+0 / -0

12 months ago
Merci !
+0 / -0
quote:
Allied units can loiter much closer to factories without being told to go away.


Thanks a lot.
+3 / -0

12 months ago
quote:

Morph rate 5/5/7.5/7.5/10/10/10... -> 5/7.5/10/12.5/15/15/15... per level


the rate should keep growing past 15 to 25 or so.
+0 / -0
12 months ago
"without beeing told to go away" - is there a way to permanently completely disable it?
+0 / -0
have heard from tank factory have new unit what missing box on tank factory


do you have updated on that yet and what are you working on right now GoggleFrog

is there way to screenshot

for some reason didn't let me show it

https://twitter.com/dohieu1970/status/1596665244738273280/photo/1

https://github.com/dohieu1970/zerok

+1 / -0
12 months ago
For me on AMD, when some player in chat writes some nonstandard character (like Azbuka, that weird German "B", Czech characters like í, ú, é, the messages are broken.
+0 / -0

12 months ago
I was also having weird graphics glitches with the ocean in this battle:

https://zero-k.info/Battles/Detail/1503683

The ocean waves would glitch out, sometimes the entire ocean would be covered with foamy waves, and sometimes there would be straight, unnatural lines where the waves would be cut off.

Also, in this game, someone made a newton mechanism that launched gunships off the side of the map, and the player was then able to control the gunships, and bring them back onto the map on the enemies' back lines. I'm not sure if this is intended or not (I don't think it is), but someone should let you know.
+0 / -0


12 months ago
quote:
"without beeing told to go away" - is there a way to permanently completely disable it?

Possibly, but I'm not going to do so because without anything being told to move there would be no way to clear the build zone. It is a very useful feature at low radius.

quote:
have heard from tank factory have new unit what missing box on tank factory
do you have updated on that yet and what are you working on right now GoggleFrog

Could you rephrase or send a screenshot? I don't know what you're saying.

quote:
I was also having weird graphics glitches with the ocean in this battle:

This sounds like a driver issue. Perhaps change drivers or ask in #support.
+1 / -0
12 months ago
https://zero-k.info/Forum/Post/255015#255015 updated message
+2 / -0
12 months ago



+5 / -0

12 months ago
I'm not sure if it's to do with this update or a different recent one, but recently USrankTomBodett and I have been getting way more lag than we ever used to, and this last game we played was almost unplayable.
+0 / -0
12 months ago
Thank you a lot for the update guys!

Keep it up !
+1 / -0
The text thing should be fixed with an update in the next half hour or so.

Edit: Actually AI needs rebuilding, so possibly in a day or two.
+4 / -0

Updated to v1.10.12.0 for fixes with engine version 105.1.1-1388-g2449603


  • Fixed an AMD graphics font issue, and possibly a few others.
  • Fixed a movement regression which let units push each other around way too easily.
  • Made use of a new feature that makes most deployed units (eg Crab and Tremor) much harder to push.
  • Tremor closes when shoved too quickly, but this is now near-impossible now without gravity weapons.
  • Transports drop their cargo at the start of a crash rather than the end, to prevent weirdness that can result from "unloading" underground on death.
  • Selecting a control group no longer consumes the keypress if the group is empty.
  • Fixed some terraform visual problems when switching between teams as a spectator without fullview.
  • Fixed a potential desync.
+8 / -0
12 months ago
quote:
AMD graphics issues

I have a weird bug, I am almost certain it started from this update.
Certain menus (the LuaUI menus), like the build menu cause a short lag spike when opened. This means whenever I select a fac or use a builder to build a thing I get a lag spike. I suspect some degraded LuaUI performance - the previously moderately laggy player menu (the one opened by the tab key) is now causes extreme lag when opened.

I have a RX 580 8GB graphics card, and I use Linux. Previously there was no lag.
+0 / -0


12 months ago
I just made a small engine update to remove a test that was crashing for some people.

quote:
I have a weird bug, I am almost certain it started from this update.
Certain menus (the LuaUI menus), like the build menu cause a short lag spike when opened. This means whenever I select a fac or use a builder to build a thing I get a lag spike. I suspect some degraded LuaUI performance - the previously moderately laggy player menu (the one opened by the tab key) is now causes extreme lag when opened.

What do you mean by the LuaUI menus? It is weird that something would be unaffected. We could probably profile the build menus for a fix. The player menu lags for everyone, I think I would rather have it rewritten then delve into it.
+1 / -0